5 способов загрузки из Excel в 1С

Публикация № 1411881 29.03.21

Пользовательские инструменты - Загрузка и выгрузка в Excel

excel загрузка

Конфигурация, состоящая из внешнего источника данных и одной обработки. Обработка содержит 5 примеров, как можно загрузить данные в 1С из Excel.

Протестировано на платформе: 8.3.18.1334, 8.3.20.1710

Написано в EDT: 2020.6.2.8

В конфигурации 1 обработка и 1 внешний источник данных, который нужен для реализации загрузки одного из вариантов. Добавлен общий макет для проверки скорости загрузки на вашем железе.

Модуль формы разбит на области, для удобного копирования в свои обработки или изучения способа загрузки.

 

 

Работа с Excel через OLE на сервере

#Область OLEСервер

&НаКлиенте
Процедура ЗагрузкаНаСервереOLE(Команда)
	Объект.Таблица1.Очистить();
	
	ТекДатаВремя = ТекущаяДата();
	
	нФайл = Новый Файл(ИмяФайла);
	
	//Если НЕ нФайл.Существует() Тогда
	//	Возврат;
	//КонецЕсли;
	
	ДвоичДанные = Новый ДвоичныеДанные(ИмяФайла);
	
	ОбработкаОЛЕНаСервере(ДвоичДанные, нФайл.Расширение);
	
	ИтоговоеВремя = ТекущаяДата() - ТекДатаВремя;
	
	Сообщить(ИтоговоеВремя);
КонецПроцедуры

&НаСервере
Процедура ОбработкаОЛЕНаСервере(ДвоичДанные, Расширение)
	ФайлЭксельНаСервере = ПолучитьИмяВременногоФайла(Расширение);
	ДвоичДанные.Записать(ФайлЭксельНаСервере);

	Попытка
		Эксель = Новый COMОбъект("Excel.Application");
		Эксель.DisplayAlerts = 0;
		Эксель.Visible = 0;
	Исключение
   		Возврат;
	КонецПопытки;
	
	ЭксельКнига = Эксель.Workbooks.Open(ИмяФайла);	
	КоличествоСтраниц = ЭксельКнига.Sheets.Count;
	
	// Перебираем все листы
	Для НомерЛиста = 1 По КоличествоСтраниц Цикл 
		Лист = ЭксельКнига.Sheets(НомерЛиста);
		КоличествоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;
		КоличествоКолонок = Лист.Cells(1, 1).SpecialCells(11).Column;

		// Перебираем строки
		Для НомерСтроки = 1 По КоличествоСтрок Цикл 
			Нстр = Объект.Таблица1.Добавить();
			Нстр.КолонкаКод	= Лист.Cells(НомерСтроки, 1).Value;
			Нстр.Колонка2	= Лист.Cells(НомерСтроки, 2).Value;
			Нстр.Колонка3	= Лист.Cells(НомерСтроки, 3).Value;
			Нстр.Колонка4	= Лист.Cells(НомерСтроки, 4).Value;
			//// Перебираем колонки
			//Для НомерКолонки = 1 По КоличествоКолонок Цикл
			//	ЗначениеВЯчейке = Лист.Cells(НомерСтроки, НомерКолонки).Value;
			//	// ...
			//	Сообщить(ЗначениеВЯчейке); // Обрабатываем занчение
			//	// ...
			//КонецЦикла;
		КонецЦикла;	
	КонецЦикла;	 
	
	Эксель.Workbooks.Close();
	Эксель.Application.Quit();
КонецПроцедуры

#КонецОбласти

Работа с Excel используя внешний источник данных

#Область ВнешнийИсточникДанных

&НаКлиенте
Процедура ЗагрузкаСПомощьюВнешнегоИсточникаДанных(Команда)
	Объект.Таблица1.Очистить();
	
	ТекДатаВремя = ТекущаяДата();
	
	ЗагрузкаСПомощьюВнешнегоИсточникаДанныхНаСервере();
	
	ИтоговоеВремя = ТекущаяДата() - ТекДатаВремя;
	Сообщить(ИтоговоеВремя);
КонецПроцедуры

&НаСервере
Процедура ЗагрузкаСПомощьюВнешнегоИсточникаДанныхНаСервере()
	Объект.Таблица1.Очистить();
	ПараметрыПодключения = Новый ПараметрыСоединенияВнешнегоИсточникаДанных;
	
	ПараметрыПодключения.СтрокаСоединения =
	"Driver={Microsoft Excel Driver (*.xls, *.xlsx, *.xlsm, *.xlsb)};DBQ=" + ИмяФайла + ";";
	
	ВнешниеИсточникиДанных.Excel.УстановитьОбщиеПараметрыСоединения(ПараметрыПодключения);
	ВнешниеИсточникиДанных.Excel.УстановитьСоединение();
	
	//Запрос = Новый Запрос("ВЫБРАТЬ
	//             |	ExcelТаблицаТаблица1.КолонкаКод,
	//             |	ExcelТаблицаТаблица1.Колонка2,
	//             |	ExcelТаблицаТаблица1.Колонка3 КАК Колонка3
	//             |ИЗ
	//             |	ВнешнийИсточникДанных.Excel.Таблица.Таблица1 КАК ExcelТаблицаТаблица1
	//             |ГДЕ
	//             |	ExcelТаблицаТаблица1.Колонка3 > 1
	//             |УПОРЯДОЧИТЬ ПО
	//             |	Колонка3");
	
		Запрос = Новый Запрос("ВЫБРАТЬ
	             |	ExcelТаблицаТаблица1.КолонкаКод,
	             |	ExcelТаблицаТаблица1.Колонка2,
	             |	ExcelТаблицаТаблица1.Колонка3 КАК Колонка3,
				 |	ExcelТаблицаТаблица1.Колонка4 КАК Колонка4
	             |ИЗ
	             |	ВнешнийИсточникДанных.Excel.Таблица.Таблица1 КАК ExcelТаблицаТаблица1");

	ТаблицаЭксельВ1с = Запрос.Выполнить().Выгрузить();
	Объект.Таблица1.Загрузить(ТаблицаЭксельВ1с);
	//Для Каждого Стр Из ТаблицаЭксельВ1с Цикл
	//	Сообщить(Стр); // Обрабатываем
	//КонецЦикла;	
КонецПроцедуры

Работа с Excel через OLE на клиенте

#Область OLEКлиент

&НаКлиенте
Процедура ЗагрузкаНаКлиентеOLE(Команда)
	Объект.Таблица1.Очистить();
	
	ТекДатаВремя = ТекущаяДата();
	
	Попытка
		Эксель = Новый COMОбъект("Excel.Application");
		Эксель.DisplayAlerts = 0;
		Эксель.Visible = 0;
	Исключение
   		Сообщить(ОписаниеОшибки()); 
   		Возврат;
	КонецПопытки;
				
	ЭксельКнига = Эксель.Workbooks.Open(ИмяФайла);	
	КоличествоСтраниц = ЭксельКнига.Sheets.Count;
	
	// Перебираем все листы
	Для НомерЛиста = 1 По КоличествоСтраниц Цикл 
		Лист = ЭксельКнига.Sheets(НомерЛиста);
		КоличествоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;
		КоличествоКолонок = Лист.Cells(1, 1).SpecialCells(11).Column;

		// Перебираем строки
		Для НомерСтроки = 1 По КоличествоСтрок Цикл 
			 Нстр = Объект.Таблица1.Добавить();
			Нстр.КолонкаКод	= Лист.Cells(НомерСтроки, 1).Value;
			Нстр.Колонка2	= Лист.Cells(НомерСтроки, 2).Value;
			Нстр.Колонка3	= Лист.Cells(НомерСтроки, 3).Value;
			Нстр.Колонка4	= Лист.Cells(НомерСтроки, 4).Value;
			// Перебираем колонки
			//Для НомерКолонки = 1 По КоличествоКолонок Цикл
			//	ЗначениеВЯчейке = Лист.Cells(НомерСтроки, НомерКолонки).Value;
			//	// ...
			//	Сообщить(ЗначениеВЯчейке); // Обрабатываем занчение
			//	// ...
			//КонецЦикла;
		КонецЦикла;	
	КонецЦикла;
		
	Эксель.Workbooks.Close();
	Эксель.Application.Quit();
	
	ИтоговоеВремя = ТекущаяДата() - ТекДатаВремя;
	Сообщить(ИтоговоеВремя);
КонецПроцедуры

#КонецОбласти

Загрузка в табличный документ

#Область ТабличныйДокумент

&НаСервере
Процедура ЗагрузкаВТабличныйДокументНаСервере()
	табДок = Новый ТабличныйДокумент;
	
	Попытка
		табДок.Прочитать(ИмяФайла);
	Исключение
		Возврат;
	КонецПопытки;
	
	нТабзнч = Новый ТаблицаЗначений;
	
	нТабзнч.Колонки.Добавить("КолонкаКод",	Новый ОписаниеТипов("Строка"));
	нТабзнч.Колонки.Добавить("Колонка2",	Новый ОписаниеТипов("Строка"));
	нТабзнч.Колонки.Добавить("Колонка3",	Новый ОписаниеТипов("Строка"));
	нТабзнч.Колонки.Добавить("Колонка4",	Новый ОписаниеТипов("Строка"));
	
	КоличествоСтрок = табДок.ВысотаТаблицы;
	
	Для сч = 2 По КоличествоСтрок Цикл 
		
		нСтр = нТабзнч.Добавить();		
		
		Попытка
			нСтр.КолонкаКод	= Строка(табДок.ПолучитьОбласть("R" + Формат(сч, "ЧГ=0;") + "C" + 1).ТекущаяОбласть.Текст);
			нСтр.Колонка2	= Строка(табДок.ПолучитьОбласть("R" + Формат(сч, "ЧГ=0") + "C" + 2).ТекущаяОбласть.Текст);
			нСтр.Колонка3	= Строка(табДок.ПолучитьОбласть("R" + Формат(сч, "ЧГ=0") + "C" + 3).ТекущаяОбласть.Текст);
			нСтр.Колонка4	= Строка(табДок.ПолучитьОбласть("R" + Формат(сч, "ЧГ=0") + "C" + 4).ТекущаяОбласть.Текст);
		Исключение
			Сообщение		= Новый СообщениеПользователю;
			Сообщение.Текст	= "Не удалось загрузить строку " + Строка(сч);
			Сообщение.Сообщить();
		КонецПопытки;
		
	КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузкаВТабличныйДокумент(Команда)
	Объект.Таблица1.Очистить();
	
	ТекДатаВремя = ТекущаяДата();
	
	ЗагрузкаВТабличныйДокументНаСервере();
	
	ИтоговоеВремя = ТекущаяДата() - ТекДатаВремя;
	Сообщить(ИтоговоеВремя);
КонецПроцедуры

#КонецОбласти

Работа с Excel через построитель

#Область ТабличныйДокументv2Построитель

&НаКлиенте
Процедура ЗагрузкаВТабличныйДокументv2(Команда)
	Объект.Таблица1.Очистить();
	
	ТекДатаВремя = ТекущаяДата();
	
	ЗагрузкаВТабличныйДокументНаСервереv2();
	
	ИтоговоеВремя = ТекущаяДата() - ТекДатаВремя;
	Сообщить(ИтоговоеВремя);
КонецПроцедуры

&НаСервере
Процедура ЗагрузкаВТабличныйДокументНаСервереv2()
	ТабДок = Новый ТабличныйДокумент;
	ТабДок.Прочитать(ИмяФайла);
	
	ОбластиТаб = ТабДок.Область(1, 1, ТабДок.ВысотаТаблицы, ТабДок.ШиринаТаблицы);
	
	Построитель = Новый ПостроительЗапроса;
	Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ОбластиТаб);  
	Построитель.Выполнить();
	
	ТабДанные = Построитель.Результат.Выгрузить();	
	Объект.Таблица1.Загрузить(ТабДанные);
	
	//Для Каждого Стр Из ТабДанные Цикл 
	//	Сообщить(стр); // Обрабатываем	
	//КонецЦикла;

КонецПроцедуры

#КонецОбласти

 

Скачать файлы

Наименование Файл Версия Размер
5 способов загрузки из Excel в 1с:

.cf 270,98Kb
56
.cf 1.0.0.2 270,98Kb 56 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ManyakRus 455 29.03.21 10:16 Сейчас в теме
надо было померить скорость работы заодно :) разных способов
2C_prog; Hexed; Medvedkov-85; qwed557; +4 Ответить
2. elephant_x 94 29.03.21 10:18 Сейчас в теме
(1) Хорошая идея. Вечером пожалуй сделаю, дополню статью, и добавлю тестовый файл)
Hexed; Cmapnep; +2 Ответить
20. user1574479 18.08.22 21:06 Сейчас в теме
21. elephant_x 94 18.08.22 23:00 Сейчас в теме
(20) Обновил публикацию, добавил в конфигурацию файл excel на 8000+ строк в общий макет. У меня все загружается за 0 секунд, искать сервер послабее сейчас нет возможности. Если конфигурацию не качал, просто скопируй код из текста и создай файл с 4 колонками.
user1574479; +1 Ответить
4. qwed557 30 14.04.21 23:39 Сейчас в теме
(1) плюсую , думаю еще надо не только скорость мерить, но и тестировать на больших файлах (больше Гб), возможно какой то из методов не сможет переварить такой файл, плюс посмотреть на загрузку системы в момент обработки. Если какой то из методов скажем так будет ложить сервер, неудобно перед пользователями получиться.
Hexed; ybatiaev; +2 Ответить
22. elephant_x 94 18.09.22 00:01 Сейчас в теме
(4)
переварить
если вышлю вам обработку сможете потестить на таком большом файле и написать результаты?
3. ManyakRus 455 30.03.21 09:41 Сейчас в теме
И ещё хорошо бы "выбрать" самый лучший способ из всех(голосовалку :-). Я использую "Загрузка в табличный документ" т.к. тогда не надо устанавливать Excel, в том числе на сервере.
Ryo3000; elephant_x; Hexed; 24rus; it_molotok; Ali1976; itoptimum; Jimbo; +8 Ответить
7. Hexed 2 14.03.22 12:55 Сейчас в теме
(3) То что в статье называется "Загрузка в табличный документ" подразумевает перебор полей, а это быть ресурсоемкая процедура. Последний вариант с загрузкой в табличный документ через построитель думаю будет правильней использовать.
elephant_x; +1 Ответить
5. Yashazz 4343 20.02.22 17:19 Сейчас в теме
Я, в общем, тоже пользовался ADO, но "со стороны экселя": https://infostart.ru/public/312528/
6. Hexed 2 14.03.22 12:53 Сейчас в теме
Спасибо за статью. Годнота.
Голосую за работу с Excel через построитель из за не критичности к установке клиента и запрос без перебора полей табличного докумнета.
elephant_x; +1 Ответить
8. elephant_x 94 15.03.22 10:11 Сейчас в теме
(6) Никак не найду время дописать, что бы можно было замерить время)
9. AlexeyZol 22.03.22 13:44 Сейчас в теме
Спасибо. А есть опыт: какой способ можно использовать при написании расширений в облаке 1CFresh.com?
10. elephant_x 94 22.03.22 21:58 Сейчас в теме
(9) Давно что-то делал, но что использовал не помню. Для фреша в один раз всего обработку писал, но клиент модерации не дождался ушел на приватный сервер)
11. mikl79 114 06.07.22 10:19 Сейчас в теме
Добрый день.
После обновления Excel с 2013 на 2019 на сервере перестала работать загрузка в 1С из Excel,
ошибка происходила здесь:
ЭксельКнига = Эксель.Workbooks.Open(ИмяФайла);

вообще когда подключаешься к Excel, т.е. в этот момент
Эксель = Новый COMОбъект("Excel.Application");

то он 1С не видит параметры ком-объекта


Поэтому переписал загрузку через построитель, спасибо большое!
Может конечно есть решение - как восстановить обмен через OLE?
13. elephant_x 94 06.07.22 12:39 Сейчас в теме
(11) Попрошу админа создать виртуалку с 2019 офисом, посмотрю в чем проблема.
(12) Через внешний источник нужно устанавливать драйвер
14. mikl79 114 06.07.22 12:40 Сейчас в теме
16. mikl79 114 07.07.22 15:18 Сейчас в теме
(13), добрый день, не разобрались в проблеме?
17. elephant_x 94 08.07.22 09:43 Сейчас в теме
(16) Пока не успел, на выходных запланировал посмотреть.
19. mikl79 114 18.07.22 08:42 Сейчас в теме
(11), помогло вот это:
Администирование-СлужбыКопонентов-Компютеры-МойКомпютер-настройка DCOM-Microsoft Excel application- Свойства-Удостоверение: Текущий пользователь
12. mikl79 114 06.07.22 12:37 Сейчас в теме
Через внешний источник не удалось подключиться к Excel, что на 2013, что на 2019 Excel.
Пишет: "... возможно драйвер не позволяет получать параметры строки соединения"
Поэтому у меня работает только через ТабДок.
Вот и проголосовал )
15. elephant_x 94 06.07.22 12:47 Сейчас в теме
(14)
Возможно excel не прописан в системе как источник данных, https://its.1c.ru/db/v838doc#bookmark:dev:TI000000848 вот тут можно прочитать как добавить

Для получения строки подключения к другим источникам данных (Excel, Access, другие СУБД) можно воспользоваться сайтом https://www.connectionstrings.com (на английском языке).

Вот тут можно посмотреть: http://msdn.microsoft.com/en-us/library/windows/desktop/ms715364(v=vs.85).aspx
18. jollyk 13.07.22 18:09 Сейчас в теме
При загрузке с помощью построителя имя колонки в табличной части должно совпадать с значением в первой строке учуда. Либо вы заполняете их вручную либо перед выгрузкой добавляете колонки. Примерно так.
&НаСервере
Процедура ДобавитьКолонки(ТабДанные) 
	
	Для Каждого Столбец Из ТабДанные.Колонки Цикл		
		нРеквизиты = Новый Массив;
		нРеквизиты.Добавить(Новый РеквизитФормы(Столбец.Имя, Новый ОписаниеТипов("Строка"), "Объект.тчЗагрузка", Столбец.Имя, Истина));
		ИзменитьРеквизиты(нРеквизиты);		
		нЭлемент = Элементы.Добавить(Столбец.Имя, Тип("ПолеФормы"), Элементы.тчЗагрузка); 
		нЭлемент.Вид = ВидПоляФормы.ПолеВвода; 
		нЭлемент.ПутьКДанным = "Объект.тчЗагрузка." + Столбец.Имя;		
	КонецЦикла	 
КонецПроцедуры
Показать
elephant_x; +1 Ответить
Оставьте свое сообщение

См. также

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    16713    33    Дмитрий74Чел    9    

Парсинг Excel-файла

Загрузка и выгрузка в Excel Универсальные функции Платформа 1С v8.3 1С:Розница 1С:Управление нашей фирмой 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Шаблон внешней обработки для парсинга Excel без использования COM-объектов, с учетом клиент-серверного взаимодействия, на толстом, тонком и веб-клиенте. С учетом требований безопасности и отображением длительных операций.

1 стартмани

15.09.2020    13257    37    LamerSoft    0    

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    10024    28    wonderboy    0    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    79540    372    Tatitutu    50    

Простой способ загрузить файл Excel на тонком клиенте.

Загрузка и выгрузка в Excel Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Самый простой способ загрузить файл Excel на тонком клиенте - это скопировать лист Excel в "табличный документ" на форме обработки и обрабатывать уже поля "табличного документа".

1 стартмани

30.10.2019    15044    5    John_d    16    

Загрузка из Excel (без использования com-объектов, без установленного Excel)

Обработка документов Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка не использует com-объект для чтения из файла, не нужен установленный Excel.

1 стартмани

22.03.2019    32983    309    Смешной 1С    29    

Конфигурация "Обмен данными Excel"

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Что будет, если скрестить Конвертацию 2.0, Модуль загрузки преобразования в значения БД от конвертации 3.0 и Excel шаблоны? Правильно, получится отличная подсистема "Обмен данными Excel", которую можно встраивать в существующие конфигурации и получить универсальный механизм по загрузке данных из Excel и вводу начальных данных. Данная подсистема позволит заменить множество различных обработок по загрузкам из Excel. Хочу отметить, что все интеграции через веб сервисы 1С по загрузкам soap пакетов (документов xml) можно адаптировать и универсально загружать через данную подсистему, правда, это потребует двух доработок конфигурации, но это возможно, архитектурное решение и идея включены в подсистему "Обмен данными Excel" и хочу Вам сообщить, что уже реализованы и доступны в новом обновлении 1.1.1.1.

2 стартмани

05.03.2019    14624    31    Алексей777    20    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    73557    536    primat    35    

Шаблон загрузки из Excel штатными средствами платформы 8.3 (без com, ado, Excel Application) (обычные и управляемые формы)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Шаблон для быстрой загрузки из Excel (форматы *.xls, *.xlsx) средствами платформы 8.3 с помощью табличного документа. Не нужно работать с MSExcel.Application, ADO. В платформе 8.3 у табличного документа развили метод Прочитать(), и сейчас можно загружать данные не только из файлов *.mxl, но и *.xls и *.xlsx. Подробнее в описании.

1 стартмани

07.12.2018    23540    107    DarkPinch222    4    

Инструменты бухгалтера: Загрузка из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Почему в решениях 1С нет простой и удобной загрузки данных из Excel в документ? Функционал более чем востребован. Есть обработка "Загрузка данных из табличного документа", очень функциональная, но простой и удобной ее не назовешь. Предлагаю простой инструмент для загрузки данных из Excel в любой документ. Обработка реализована в виде внешней обработки заполнения объект и интегрируется в форму документа, данные загружаются в два клика из самого документа. Так же удобство обеспечивается простой и гибкой настройкой сопоставления колонок и реквизитов, для каждого реквизита табличной части настраивается из какой колонки брать значение и как его загружать, загружать как есть или это например, код номенклатуры и по нему нужно искать в справочнике.

1 стартмани

21.11.2018    8826    110    Bazil    20    

Универсальное средство чтения файлов Excel Промо

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Унифицируем чтение файлов Excel, читаем "неудобные" файлы, переносим содержимое таблиц Excel через буфер обмена.

5 стартмани

27.03.2013    37814    170    Infector    4    

Загрузка номенклатуры (с реквизитами, свойствами, несколькими единицами измерений и их коэффициентами, объемами, весами и штрихкодами), прайсов, счетов, накладных, УПД и прочих товарных документов из Excel для Управление торговлей 10.3

Загрузка и выгрузка в Excel Оптовая торговля Ценообразование, анализ цен Прайсы Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 Управленческий учет Абонемент ($m)

Загружает номенклатуру, единицы измерения (вес и объем), штрихкоды (поддерживается одновременная загрузка нескольких единиц и штрихкодов), реквизиты и свойства номенклатуры, номера ГТД и серии. Загрузка производится во все документы в которых поддерживается механизм подбора номенклатуры (Заказ покупателя, Поступление товаров и услуг, Установка цен номенклатуры и многие другие). Ищет номенклатуру по наименованию, артикулу, штрихкоду и аналогичным полям в номенклатуре контрагентов. Работает в УТ 10.3 (весьма вероятно будет работать в КА 1 и УПП). Для работы необходима платформа не ниже 8.3.6. Наличие установленного Excel на компьютере не обязательно. Не загружает изображения! Не работает в БП, УТ 11, Рознице 2, УНФ и прочих новых конфигурациях!

3 стартмани

07.10.2018    17712    67    1c.pro.fun    21    

Выгрузка отчета в Excel с формулами, используя заполнение - шаблон макета для сложных формул

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Каждому программисту 1с, хоть раз, да приходилось писать выгрузку отчета из 1С в Excel с формулами. Есть много вариантов как это сделать. Но мне захотелось это сделать "по нормальному", используя как можно меньше кода выгрузки в excel, и так чтобы проще было дорабатывать. Идея была проста, все формулы засунуть в макет, и при выводе в Excel просто "проинициализировать" их. Но меня ждал облом, который мне пришлось героически преодолевать. Спойлер - в итоге все получилось...)

1 стартмани

18.07.2018    18789    51    _root    17    

Загрузка УПД в Бухгалтерию 3.0.111.16 из Excel Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0.111.16, с заведением номенклатуры в справочник , добавлением ГТД, стран происхождения.

1 стартмани

20.10.2015    34478    35    teyana    28    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    39059    64    m-rv    34    

Загрузка данных из Excel Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Загружает информацию из файлов Excel в любой документ, в шапку документа и в любую табличную часть. Сняты ограничения по количеству загружаемой информации... Теперь есть возможность сохранить настройки формы.

1 стартмани

02.04.2012    56405    1041    TSer1    80    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    96481    166    alexey.kutya    103    

Загрузка данных из табличного документа (управляемое приложение)

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Загрузка данных из табличного документа для управляемого приложения. По функционалу схожа с типовой обработкой ИТС для обычного приложения.

1 стартмани

10.10.2017    19875    256    karpal    20    

Загрузка из Excel-файла данных в документ Поступление товаров и услуг

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Розничная торговля Склад и ТМЦ Платформа 1С v8.3 1С:Розница 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Загрузка из произвольного Excel-файла документов Поступление товаров и услуг с возможностью создания номенклатуры, обработка позволяет автоматизировать процесс оформления новых поступлений товара.

1 стартмани

04.03.2017    46213    515    gzharkoj    138    

Выгрузка в XML и загрузка из XML. Пример с передачей файла с клиента на сервер и обратно

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Столкнулся с проблемой передачи файла с клиента на сервер и обратно для выгрузки и загрузки данных в XML. Много примеров для выгрузки/загрузки, но не встретил ни одного, где описывался бы механизм передачи файла на сервер и обратно

1 стартмани

03.02.2017    76032    98    Anchoret    6    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    60244    8    milkers    2    

Групповая обработка номенклатуры "Крутотенюшка": выгрузка из 1С в Excel, правка и обратная загрузка в 1С с учетом изменений

Загрузка и выгрузка в Excel Платформа 1С v8.3 1С:Управление торговлей 10 Абонемент ($m)

Эта обработка очень поможет при свертках, переносах, и т.д., когда нужно провести ревизию имеющейся номенклатуры, убрать лишнее, отредактировать, изменить реквизиты, добавить свойства и загрузить все с учетом выполненных изменений в 1С.

1 стартмани

11.04.2016    29942    69    O-Planet    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    295636    567    Zerocl    90    

Программная работа с Excel из 1Сv8 - кнопки, макросы, области, отображение листов и полос прокрутки при открытии

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Буду краток, представленная информация здесь это пример работы с Excel программно из 1С, от начала - создание COMОбъект("Excel.Application"), до конца его закрытия. Тут представлен пример, как создать кнопку, присвоить ей макрос, затем добавить лист, прописать в ячейки необходимую информацию, затем установка нужного листа в момент при открытии Excel, корректное отображение листов и полосы прокрутки, затем сохранение файла в необходимый формат. Данная статья не уникальна, само собой, но в данном контексте она консолидирует информацию от различных источников и призвана только помочь в познании методов программной работы с Excel как полноценный законченный пример. Предполагается, что читатель уже имеет опыт в создании СКД отчетов.

1 стартмани

29.07.2015    21192    34    sergik_nsk    5    

Обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие

Прайсы Обработка документов Загрузка и выгрузка в Excel Ценообразование, анализ цен Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Универсальная программа для загрузки Прайс-листов в базу 1С:Предприятия 8. Основные достоинства: простота использования и широкие функциональные возможности поиска товаров для записи цен. Область применения: обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие.

10 стартмани

16.07.2015    41937    4    Destroy    2    

Просмотр файлов разных форматов (PDF, DOC, XLS, MXL, видео, картинок и др.) в управляемой форме 1С

Работа с интерфейсом Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Просмотр файлов разных форматов (PDF, DOC, XLS, MXL, видео, картинок и др.) в управляемой форме 1С. Не надо веб-сервера, ActiveX и т.д.

8 стартмани

23.06.2015    53712    127    sss123    32    

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    39260    72    Tatitutu    14    

Загрузка товаров из таблицы в реализацию и поступление УТ 10.3 по артикулу и производителю + создание товаров и ГТД

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Склад и ТМЦ Платформа 1С v8.3 1С:Управление торговлей 10 Россия Управленческий учет Абонемент ($m)

Обработка встраивается в конфигурацию (только кнопка для вызова обработки) и позволяет быстро и просто загрузить список товаров в реализацию или поступление. В процессе загрузки создаются отсутствующие товары и ГТД.

2 стартмани

03.03.2015    22729    4    taurus__    0    

Работа с Excel. Объединение, Стыковка, Свертка

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет работать как с одним, так и с несколькими файлами Excel: Объединять файлы со сходной структурой в одну таблицу, Стыковать файлы с разной структурой по ключевому полю, Группировать результат по выбранным полям и суммировать числовые поля.

1 стартмани

19.02.2015    32519    44    Ekovichev    7    

Нестандартная загрузка из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Взгляд на привычную задачу под неожиданным углом - пусть пользователь прямо в Excel решает, что ему надо, и грузит в 1С только нужное. Установите любой отбор, выделите фрагмент, и вот он уже в 1С. Для обычных и УФ 8.3

1 стартмани

12.11.2014    38686    281    Yashazz    47    

Загрузка данных из табличного документа (УФ)

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Загрузка данных из табличного документа (УФ) с сохранением/восстановлением настроек, загрузкой в план счетов, загрузкой реквизитов объектов типа ПВХ

2 стартмани

22.05.2014    32403    260    blindcat2006    15    

Универсальная загрузка табличных данных из файла Microsoft Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Мастер загрузки произвольных табличных данных из книг Microsoft Excel в объекты информационной базы 1С: Предприятие (управляемое приложение).

1 стартмани

30.04.2014    34846    443    McSeem    21    

[x1c.ru] Загрузка Табеля учета рабочего времени из Excel-отчета системы "Таймформер" для ЗУП Редакция 2.5

Загрузка и выгрузка в Excel Учет рабочего времени Платформа 1С v8.3 1С:Зарплата и Управление Персоналом 2.5 Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка для загрузки данных об отработанном времени из Excel-файла системы "Таймформер". Загружает Excel-файлы, содержащие подробный месячный отчет.

1 стартмани

16.04.2014    29706    15    GusevNA    1