Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов

Публикация № 1150965

Администрирование - Администрирование данных 1С - Обработка документов

заявка открытие ЗУП ЗКГУ подбор 19 символов лицевой счет XML

Расширение добавляет кнопку "Подбор" в документ "Заявка на открытие лицевых счетов". И отключает проверку на 19 символов в латинском Фамилии, Имени при выгрузке.

По кнопке "Подбор" открывается форма списка сотрудников работающих на дату документа.

Если сотрудник работает по основному месту и внутреннему совместительству, то в документ попадет одно физическое лицо.

К сожалению при подборе на подсвечиваются уже выбранные сотрудники, т.к. форма подбора отражает справочник сотрудники, а в документе справочник физические лица.

В расширении следует отключить безопасный режим.

Тестировалась на: Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.9.229).

 

Пример кода из расширения (кнопка подбор):

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеПодборСотрудниковПосле(Команда)
	
	//ПерсонифицированныйУчетКлиент.ПодобратьФизическихЛиц(Элементы.ЛицевыеСчета, Объект.Организация, АдресСпискаПодобранныхСотрудников());
	
	ПараметрыОткрытия = Новый Структура;
	
	Отборы = Новый Структура("ПоказыватьДоговорниковГПХ", Ложь);
	ПараметрыОткрытия.Вставить("Отбор", Отборы);
			
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихВПериодеПоПараметрамОткрытияФормыСписка(
		Элементы.ЛицевыеСчета,
		Объект.Организация,
		,
		НачалоДня(Объект.Дата),
		КонецДня(Объект.Дата),
		,
		АдресСпискаПодобранныхСотрудников(),
		ПараметрыОткрытия);

КонецПроцедуры

&НаКлиенте
Процедура Расш_ПодборЗаявкаНаОткрытиеЛицевыеСчетаОбработкаВыбораПосле(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	
	 ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение);

КонецПроцедуры

&НаСервере
Процедура ЗаполнитьСтрокуНаСервереПосле(ВыбранноеЗначение)
	
	Валюта = Справочники.Валюты.НайтиПоКоду("643");
	
	СписокФизическихЛиц = Новый ТаблицаЗначений();
	СписокФизическихЛиц.Колонки.Добавить("ФизическоеЛицо", Новый ОписаниеТипов("СправочникСсылка.ФизическиеЛица"));
	
	Для каждого Строка Из ВыбранноеЗначение Цикл
		
		НоваяСтрока = СписокФизическихЛиц.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
	КонецЦикла;
	
	СписокФизическихЛиц.Свернуть("ФизическоеЛицо");
	
	Для каждого Строка Из СписокФизическихЛиц Цикл
		
		НоваяСтрока = Объект.Сотрудники.Добавить();
		НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
		
		ДокументОбъект = РеквизитФормыВЗначение("Объект");
		ДокументОбъект.ЗаполнитьСтрокуТабличнойЧастиДаннымиДляОткрытияЛицевыхСчетов(ДокументОбъект.Дата, НоваяСтрока.НомерСтроки);
		ЗначениеВРеквизитФормы(ДокументОбъект, "Объект")
		
	КонецЦикла;
	
	Для каждого Строка Из Объект.Сотрудники Цикл
		
		//Строка.ЯвляетсяЗарплатнойКартой = Истина;
		Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
		Строка.ВалютаВклада = Валюта;
		
	КонецЦикла;
		
КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов:
.cfe 49,40Kb
08.11.19
13
.cfe 49,40Kb 13 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. DJDUH 17 08.11.19 15:29 Сейчас в теме
Запрос в цикле, ай-я-я-й-й!!!

Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Справочники.Валюты.НайтиПоКоду("643");
		
КонецЦикла;
Показать



Валюта643 = Справочники.Валюты.НайтиПоКоду("643");
Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Валюта643 ;
		
КонецЦикла;
Показать
2. GeterX 699 08.11.19 17:04 Сейчас в теме
3. chesnokov-a-v 99 17.12.19 14:35 Сейчас в теме
Установил расширение, но кнопка "Подбор" не появилась. ЗУП 3.1.11.133
4. GeterX 699 17.12.19 14:40 Сейчас в теме
(3) в описании написано: "В расширении следует отключить безопасный режим."
5. chesnokov-a-v 99 17.12.19 20:06 Сейчас в теме
(4) конечно это было сделано. попробую разобраться в проблеме чуть позже.
6. GeterX 699 17.12.19 20:24 Сейчас в теме
(5) попробуйте поискать в меню Ещё табличной части документа.
7. chesnokov-a-v 99 18.12.19 11:28 Сейчас в теме
(6) Появилась. Удалил расширение и добавил заново, с несколькими перезапусками (магия).
8. Amras 43 20.12.19 09:41 Сейчас в теме
Так попроще будет, а уж добавить команду (ПодобратьСотрудников) на форму, думаю, труда не составит. И при всем при этом используем исключительно типовые механизмы (протестировано на ЗУП КОРП 3.1.10.223), кроме получения ФизическогоЛица.

&НаКлиенте
Процедура ПодобратьСотрудников(Команда)
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихНаДатуПоПараметрамОткрытияФормыС­писка(
		Элементы.ЛицевыеСчета,,,,,АдресСпискаПодобранныхСотрудников());
КонецПроцедуры
	
// Возвращает адрес во временном хранилище массива уже подобранных сотрудников.
//
&НаСервере
Функция АдресСпискаПодобранныхСотрудников()
	СписокСотрудников = Объект.Сотрудники.Выгрузить(,"ФизическоеЛицо").ВыгрузитьКолонку("ФизическоеЛицо");
	
	Возврат ПоместитьВоВременноеХранилище(СписокСотрудников, УникальныйИдентификатор);
КонецФункции

&НаКлиенте
Процедура ЛицевыеСчетаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Для каждого ВыбранныйСотрудник Из ВыбранноеЗначение Цикл
		
		мФизЛицо = МГ_ПолучитьФизЛицо(ВыбранныйСотрудник);
		
		Если Объект.Сотрудники.НайтиСтроки(Новый Структура("ФизическоеЛицо", мФизЛицо)).Количество() = 0 Тогда
			НовыйСотрудник = Объект.Сотрудники.Добавить();
			НовыйСотрудник.ФизическоеЛицо = мФизЛицо;
			
			ЗаполнитьСтрокуНаСервере(НовыйСотрудник.НомерСтроки);
			
			Модифицированность = Истина;
		КонецЕсли;
	КонецЦикла; 
КонецПроцедуры

&НаСервере
Функция МГ_ПолучитьФизЛицо(Сотрудник)
	Возврат Сотрудник.ФизическоеЛицо;
КонецФункции
Показать
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 УТ11 Россия Абонемент ($m) Работа с интерфейсом

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    5441    7    bmk74    1       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Списание (корректировка) задолженности контрагентов УНФ 1.6

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УНФ Украина БУ Дебиторская и кредиторская задолженность Абонемент ($m) Закрытие периода Обработка документов

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    8966    10    DMon    1       

Регистрация документов с измененной суммой

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка документов

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    7559    1    ryan    0       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 КА1 УПП1 УУ Абонемент ($m) Обработка документов

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    10077    12    stvorl    6       

Шпаргалка разработчика для работы с формами

Отчеты и формы Программист Архив с данными v8 Россия Абонемент ($m) Работа с интерфейсом

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    10528    73    ELAM    3       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Открывашка ячеек таблиц

Инструменты и обработки Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    11764    11    tormozit    28       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    19986    80    asdfgcom    46       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Визуализация событий на временной шкале средствами "Поле HTML документа"

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    16853    130    Plotks2017    24       

Работа с данными выбора

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    28720    17    kalyaka    16       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    22069    5    biz-intel    3       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Копирование меню в Трактир Management

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Производство готовой продукции (работ, услуг) Абонемент ($m) Обработка документов

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    18051    2    integrator1983    0       

Программное формирование форматированной строки в стиле html+inline CSS

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    23084    29    bonv    9       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Помощник по закрытию месяца для УТ 11.3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ11 Россия УУ Закрытие периода Абонемент ($m) Закрытие периода Обработка документов

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    16135    3    Zalipaka    1       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Расширенная настройка динамического списка УФ

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    26884    146    tormozit    23       

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БУ УУ Дебиторская и кредиторская задолженность Абонемент ($m) Обработка документов Печатные формы документов

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    16821    2    denmax    2       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    32281    150    Aphanas    4       

Загрузка Счета покупателя из PDF

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Windows Оптовая торговля Абонемент ($m) Обработка документов Файловые протоколы обмена, FTP

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    9292    11    John_d    0       

​​​​​​​CorelDRAW Graphics Suite 2019 Промо

CorelDRAW – пакет профессиональных инструментов для редактирования фотографий, разработки дизайна, создания макетов страниц и векторных иллюстраций

Управление доставкой розничным покупателям

Инструменты и обработки Руководитель проекта Конфигурация (md, cf) v8 УТ10 Розничная и сетевая торговля (FMCG) Россия УУ Windows Розничная торговля Абонемент ($m) Обработка документов

Дополнение для УТ 11.1, оформление доставки для розничного покупателя на основании кассового чека в связке с мягким чеком покупателя.

5 стартмани

10.03.2016    20828    6    Denis_Viktorovich    5       

Ночное восстановление последовательности документов (фоновым заданием) для БП 3.0

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Россия Windows Абонемент ($m) Обработка документов

Внешняя обработка служит для восстановления последовательности документов в БП 3.0 за месяц, по расписанию, фоновым заданием на сервере 1С. Подключается как дополнительная обработка в режиме пользователя.

5 стартмани

25.02.2016    27779    83    SmArtist    8       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Простые радости жизни программиста 1С: выбор типа значения

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    41966    45    yuraos    17       

Перечисление НДФЛ в бюджет РФ (13%, 30%)

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 БУ НУ Windows Зарплата НДФЛ Абонемент ($m) Обработка документов

Внешняя обработка (табличных частей), предназначенная для корректного заполнения документа "Перечисление НДФЛ в бюджет РФ". Конфигурация: Зарплата и Управление Персоналом, редакция 2.5

1 стартмани

27.01.2016    25806    239    1kashak    16