Табло для 8.х

Публикация № 1109663

Разработка - Обработки - Универсальные обработки

обработка

21
Многострочный калькулятор

Вычисляет математические и логические выражения. Очень удобен для разнообразных поверочных вычислений. После набора выражения в строке для получения результата нажать Ctrl+Enter. Перед вычислением запятая преобразуется в точку, знак пробела, символ "'" и символ НПП игнорируются. Варианты для обычных и для управляемых форм.

Привожу код обработки:

Процедура ВыполнитьВычисления(СтрВыражения)
	СимволПС="";
	новтабло="";
	для с=1 по стрчислострок(СтрВыражения) цикл
		
		текстр=сокрлп(стрполучитьстроку(СтрВыражения,с));
		если текстр="" тогда 
			новтабло=новтабло+СимволПС;
			продолжить КонецЕсли;
		
		инд=найти(текстр,"=");
		если инд>0 тогда 
			текстр=сокрп(лев(текстр,инд-1));
		КонецЕсли;
		
		строкадлявычисленияшаблона=стрзаменить(текстр,",",".");
		строкадлявычисленияшаблона=стрзаменить(строкадлявычисленияшаблона,"'","");
		строкадлявычисленияшаблона=стрзаменить(строкадлявычисленияшаблона," ","");
		строкадлявычисленияшаблона=стрзаменить(строкадлявычисленияшаблона,символы.НПП,"");
		
		попытка
			
			результат=вычислить(строкадлявычисленияшаблона);
			текстр=текстр+" = "+результат;
			
		исключение
		КонецПопытки;	
		
		новтабло=новтабло+СимволПС+текстр;
		
		СимволПС=символы.ПС;
	КонецЦикла;
	
	табло=новтабло;
	
КонецПроцедуры	

 

Обработки подходят для любой конфигурации.

Обработку для управляемых форм возможно встроить в дополнительные отчеты и обработки для конфигураций, основанных на БСП. Для других конфигураций необходимо закомментировать содержимое модуля объекта обработки.

Обработки тестировались на релизе платформы: 8.3.12.1685.

21

Скачать файлы

Наименование Файл Версия Размер
Табло для обычных форм
.epf 6,34Kb
18.08.19
2
.epf 6,34Kb 2 Скачать
Табло для УФ
.epf 6,90Kb
18.08.19
1
.epf 6,90Kb 1 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Yashazz 2539 21.08.19 11:31 Сейчас в теме
Примитив. Делать, так уж делать нормально - в привычном табличном виде, да с историей вычислений, да с возможностью вызова сервера, а не такое тяп-ляп.
2. waol 259 21.08.19 14:43 Сейчас в теме
(1)делайте. Мне так достаточно удобно
3. Ilya_138 21.08.19 15:08 Сейчас в теме
Функционал комментировать не буду, но оформление...
Прикрепленные файлы:
chernov.gigansk.ru; +1 Ответить
4. Yashazz 2539 21.08.19 16:50 Сейчас в теме
а уж как оно начнёт глючить при переносе строк... пользователям такое давать нельзя, адски накосячат сразу.
5. waol 259 21.08.19 19:21 Сейчас в теме
продемонстрируйте, как оно начнет глючить. Иначе нужно будет считать, что это пустословие.
6. Yashazz 2539 25.08.19 10:55 Сейчас в теме
(5) Легко. Два-три стартмани за тестирование вашей поделки, и займусь.
7. waol 259 25.08.19 20:37 Сейчас в теме
(6)мне не требуется тестирование. Не нужно - не пользуйтесь. Зачем на вентилятор бросать
Оставьте свое сообщение